26 lines
737 B
Diff
Executable file
26 lines
737 B
Diff
Executable file
From 3ea8aa5ded2782cfb10577348fc9f56144c72d7b Mon Sep 17 00:00:00 2001
|
|
From: raahilsha-z <raahil.sha@zimaging.io>
|
|
Date: Wed, 7 Jul 2021 15:57:46 -0400
|
|
Subject: [PATCH] fix numeric literals flag
|
|
|
|
---
|
|
CMakeLists.txt | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 7cf86f74b..e07fd430a 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -420,6 +420,9 @@ endif()
|
|
|
|
# Boost (required)
|
|
include("${PCL_SOURCE_DIR}/cmake/pcl_find_boost.cmake")
|
|
+if (NOT APPLE AND NOT WIN32 AND CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
|
|
+ add_definitions(-fext-numeric-literals)
|
|
+endif()
|
|
|
|
### ---[ Create the config.h file
|
|
set(pcl_config_h_in "${CMAKE_CURRENT_SOURCE_DIR}/pcl_config.h.in")
|
|
--
|
|
2.32.0.windows.1
|
|
|