15 lines
514 B
Diff
Executable file
15 lines
514 B
Diff
Executable file
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 9d42b6e..e6d9f18 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -41,6 +41,10 @@ option(HIGHFIVE_BUILD_DOCS "Enable documentation building" ON)
|
|
option(HIGHFIVE_USE_INSTALL_DEPS "End applications by default use detected dependencies here" OFF)
|
|
mark_as_advanced(HIGHFIVE_USE_INSTALL_DEPS)
|
|
|
|
+# Allow big object
|
|
+if(MSVC)
|
|
+ add_compile_options(/bigobj)
|
|
+endif()
|
|
|
|
# Check compiler cxx_std requirements
|
|
# -----------------------------------
|