32 lines
1.2 KiB
Diff
Executable file
32 lines
1.2 KiB
Diff
Executable file
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index ad74900..42d55af 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -73,7 +73,7 @@ target_sources( date INTERFACE
|
|
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/include/date/iso_week.h>
|
|
$<BUILD_INTERFACE:${CMAKE_CURRENT_LIST_DIR}/include/date/julian.h>
|
|
)
|
|
-if (CMAKE_VERSION VERSION_GREATER_EQUAL 3.15)
|
|
+if (0)
|
|
# public headers will get installed:
|
|
set_target_properties( date PROPERTIES PUBLIC_HEADER include/date/date.h )
|
|
endif ()
|
|
@@ -144,7 +144,6 @@ if( BUILD_TZ_LIB )
|
|
endif( )
|
|
set_target_properties( date-tz PROPERTIES
|
|
POSITION_INDEPENDENT_CODE ON
|
|
- PUBLIC_HEADER "${TZ_HEADERS}"
|
|
VERSION "${PROJECT_VERSION}"
|
|
SOVERSION "${ABI_VERSION}" )
|
|
if( NOT MSVC )
|
|
@@ -169,8 +169,8 @@ write_basic_package_version_file( "${version_config}"
|
|
COMPATIBILITY SameMajorVersion )
|
|
|
|
install( TARGETS date
|
|
- EXPORT dateConfig
|
|
- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/date )
|
|
+ EXPORT dateConfig )
|
|
+install( FILES include/date/date.h ${TZ_HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/date )
|
|
export( TARGETS date NAMESPACE date:: FILE dateTargets.cmake )
|
|
if (CMAKE_VERSION VERSION_LESS 3.15)
|
|
install(
|