30 lines
848 B
Diff
Executable file
30 lines
848 B
Diff
Executable file
diff --git a/src/draco/io/parser_utils.cc b/src/draco/io/parser_utils.cc
|
|
index 6e42a58..3c302b9 100644
|
|
--- a/src/draco/io/parser_utils.cc
|
|
+++ b/src/draco/io/parser_utils.cc
|
|
@@ -152,7 +152,9 @@ bool ParseSignedInt(DecoderBuffer *buffer, int32_t *value) {
|
|
if (!ParseUnsignedInt(buffer, &v)) {
|
|
return false;
|
|
}
|
|
- *value = (sign < 0) ? -v : v;
|
|
+ if (sign < 0)
|
|
+ v *= -1;
|
|
+ *value = v;
|
|
return true;
|
|
}
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 7e79da7..c4d9880 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -70,6 +70,10 @@ draco_set_build_definitions()
|
|
draco_set_cxx_flags()
|
|
draco_generate_features_h()
|
|
|
|
+if (MSVC)
|
|
+ add_compile_options(/wd4996)
|
|
+endif()
|
|
+
|
|
# Draco source file listing variables.
|
|
list(APPEND draco_attributes_sources
|
|
"${draco_src_root}/attributes/attribute_octahedron_transform.cc"
|