22 lines
733 B
Diff
Executable file
22 lines
733 B
Diff
Executable file
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 7fdd7ddbd..f189c472c 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -9,7 +9,16 @@ project(QtImageFormats # special case
|
|
HOMEPAGE_URL "https://qt.io/"
|
|
LANGUAGES CXX C
|
|
)
|
|
-
|
|
+find_package(Threads)
|
|
+set_property(TARGET Threads::Threads PROPERTY _qt_no_promote_global TRUE)
|
|
+find_package(ZLIB)
|
|
+if(TARGET ZLIB::ZLIB)
|
|
+ set_property(TARGET ZLIB::ZLIB PROPERTY _qt_no_promote_global TRUE)
|
|
+endif()
|
|
+find_package(JPEG)
|
|
+if(TARGET JPEG::JPEG)
|
|
+ set_property(TARGET JPEG::JPEG PROPERTY _qt_no_promote_global TRUE)
|
|
+endif()
|
|
# special case begin
|
|
# Make sure we only use latest private CMake API, aka no compatibility wrappers.
|
|
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
|