16 lines
420 B
Diff
Executable file
16 lines
420 B
Diff
Executable file
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index a5fed05..7875b91 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -24,6 +24,11 @@ set (AVCPP_WARNING_OPTIONS
|
|
$<$<CXX_COMPILER_ID:MSVC>:
|
|
/W4>)
|
|
|
|
+# fixes vcpkg uwp failures due to /sdl
|
|
+if(MSVC)
|
|
+ add_compile_options(/wd4996)
|
|
+endif()
|
|
+
|
|
# -pthread sets also some useful compile-time flags
|
|
set(THREADS_PREFER_PTHREAD_FLAG ON)
|
|
find_package(Threads)
|